dpkg error processing package XXX (--configure) 解决方法 (ubuntu右上角红色警告)

在 Ubuntu 执行 sudo apt-get upgrade 时,出现了如下的报错:

dpkg: error processing package bluez (--configure):
dpkg: dependency problems prevent configuration of bluez-alsa:i386:                       
 ...等等一系列的错误

because ... have many errors
E: Sub-process /usr/bin/dpkg returned an error code (1)

解决方案:

sudo mv /var/lib/dpkg/info/ /var/lib/dpkg/info_old/
sudo mkdir /var/lib/dpkg/info/
sudo apt-get update...
sudo apt-get -f install  
sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info_old/
sudo rm -rf /var/lib/dpkg/info
sudo mv /var/lib/dpkg/info_old/ /var/lib/dpkg/info/

输入上述命令之后,在执行 sudo apt-get update 和 sudo apt-get upgrade 就不会有问题了。

参考链接:
https://blog.csdn.net/rainly1/article/details/92835769


文章作者: 陈德强
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 陈德强 !
¥
  目录